CVE-2026-114135
CVE-2026-114135 · Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Jupyter Server is the backend for Jupyter web applications. From 2.0.0 until 2.6.0, enabling GatewayClient.url replaced the normal KernelWebsocketHandler with WebSocketChannelsHandler, which authenticated the user but did not call authorizer.is_authorized(...) for the execute action on the kernels resource. A restricted authenticated user could therefore open an upstream kernel channel and obtain kernel execution despite the configured Authorizer denying that action, exposing data and credentials available to the kernel and permitting modification or disruption of the kernel environment. The default gateway configuration is fixed in version 2.6.0. In 2.6.0 and later, the same authorization bypass remains possible when a deployment manually registers the deprecated jupyter_server.gateway.handlers module, because its handler still omits the configured kernel-execute authorization decision.
CVSS 8.8 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
jupyter_server
- Softwareversionen
- >= 2.0.0, < 2.6.0: Betroffen
Keine Korrektur veröffentlicht
jupyter-server Debian:12
- Softwareversionen
- 1.23.3-1
- 1.23.3-2
- 2.14.0-1
- 2.14.2-1
- 2.14.2-2
- 2.14.2-3
- 2.14.2-4
- 2.14.2-5
- 2.15.0-1
- 2.17.0-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-3
- 2.9.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-server Debian:13
- Softwareversionen
- 2.15.0-1
- 2.17.0-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-server Debian:14
- Softwareversionen
- 2.15.0-1
- 2.17.0-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-server PyPI
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 2.5.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.6.0
Auf 2.6.0 aktualisieren
jupyter-server Ubuntu:22.04:LTS
- Softwareversionen
- 1.2.2-1
- 1.13.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-server Ubuntu:24.04:LTS
- Softwareversionen
- 1.23.3-1
- 1.23.3-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-server Ubuntu:26.10
- Softwareversionen
- 2.17.0-1
- 2.20.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-server Ubuntu:26.04:LTS
- Softwareversionen
- 2.15.0-1
- 2.17.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/jupyter-server/jupyter_server/security/advisories/GHSA-354v-3q48-cv69
- https://github.com/jupyter-server/jupyter_server/pull/1261
- https://github.com/jupyter-server/jupyter_server/commit/35ffe5d435682128da16dc144a8e9e9f8fa85dd8
- https://github.com/jupyter-server/jupyter_server/releases/tag/v2.6.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-114135