p PatchFirst

CVE-2026-118256

CVE-2026-118256 · Vue I18n: `escapeParameter` does not escape named values when the same call also passes a list

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Vue I18n is the internationalization plugin for Vue.js. From 9.0.0-beta.5 until 11.4.14 and 12.0.0-alpha.5, enabling escapeParameter, called escapeParameterHtml in the Legacy API, does not escape named interpolation values when the same translation call supplies both list and named values because escapeParams() processes only the list branch. Applications that render translations as HTML and pass untrusted named values with a list can insert attacker-controlled markup, including phishing links, forms, and layout changes, and can permit script execution when combined with the srcdoc sanitizer bypass or on releases without the sanitizer. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.

CVSS 2.1 · Faible · EPSS 0,5% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • vue-i18n

    Versions du logiciel
    • >= 9.0.0-beta.5, < 11.4.14: Concernée
    • >= 12.0.0-alpha.1, < 12.0.0-alpha.5: Concernée

    Aucun correctif publié

  • vue-i18n npm

    Plages de versions concernées
    • SEMVER: ≥ 9.0.0-beta.5, < 11.4.14

    Mettez à jour vers 11.4.14

  • vue-i18n npm

    Plages de versions concernées
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Mettez à jour vers 12.0.0-alpha.5

  • @intlify/core npm

    Plages de versions concernées
    • SEMVER: ≥ 9.0.0-beta.10, < 11.4.14

    Mettez à jour vers 11.4.14

  • @intlify/core npm

    Plages de versions concernées
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Mettez à jour vers 12.0.0-alpha.5

  • @intlify/core-base npm

    Plages de versions concernées
    • SEMVER: ≥ 9.0.0-beta.12, < 11.4.14

    Mettez à jour vers 11.4.14

  • @intlify/core-base npm

    Plages de versions concernées
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Mettez à jour vers 12.0.0-alpha.5

  • petite-vue-i18n npm

    Plages de versions concernées
    • SEMVER: ≥ 9.2.0-alpha.7, < 11.4.14

    Mettez à jour vers 11.4.14

  • petite-vue-i18n npm

    Plages de versions concernées
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Mettez à jour vers 12.0.0-alpha.5

  • @intlify/vue-i18n-core npm

    Plages de versions concernées
    • SEMVER: ≥ 9.2.0-alpha.7, < 11.4.14

    Mettez à jour vers 11.4.14

  • @intlify/vue-i18n-core npm

    Plages de versions concernées
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Mettez à jour vers 12.0.0-alpha.5

Sources originales

Vérifiez votre serveur →