p PatchFirst

CVE-2026-118256

CVE-2026-118256 · Vue I18n: `escapeParameter` does not escape named values when the same call also passes a list

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vue I18n is the internationalization plugin for Vue.js. From 9.0.0-beta.5 until 11.4.14 and 12.0.0-alpha.5, enabling escapeParameter, called escapeParameterHtml in the Legacy API, does not escape named interpolation values when the same translation call supplies both list and named values because escapeParams() processes only the list branch. Applications that render translations as HTML and pass untrusted named values with a list can insert attacker-controlled markup, including phishing links, forms, and layout changes, and can permit script execution when combined with the srcdoc sanitizer bypass or on releases without the sanitizer. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.

CVSS 2.1 · Niedrig · EPSS 0,5% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vue-i18n

    Softwareversionen
    • >= 9.0.0-beta.5, < 11.4.14: Betroffen
    • >= 12.0.0-alpha.1, < 12.0.0-alpha.5: Betroffen

    Keine Korrektur veröffentlicht

  • vue-i18n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.0.0-beta.5, < 11.4.14

    Auf 11.4.14 aktualisieren

  • vue-i18n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.0.0-beta.10, < 11.4.14

    Auf 11.4.14 aktualisieren

  • @intlify/core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/core-base npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.0.0-beta.12, < 11.4.14

    Auf 11.4.14 aktualisieren

  • @intlify/core-base npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • petite-vue-i18n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.2.0-alpha.7, < 11.4.14

    Auf 11.4.14 aktualisieren

  • petite-vue-i18n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

  • @intlify/vue-i18n-core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 9.2.0-alpha.7, < 11.4.14

    Auf 11.4.14 aktualisieren

  • @intlify/vue-i18n-core npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 12.0.0-alpha.1, < 12.0.0-alpha.5

    Auf 12.0.0-alpha.5 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →