CVE-2026-22695
CVE-2026-22695 · LIBPNG has a heap buffer over-read in png_image_read_direct_scaled (regression from CVE-2025-65018 fix)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From 1.6.51 to 1.6.53, there is a heap buffer over-read in the libpng simplified API function png_image_finish_read when processing interlaced 16-bit PNGs with 8-bit output format and non-minimal row stride. This is a regression introduced by the fix for CVE-2025-65018. This vulnerability is fixed in 1.6.54.
CVSS 6.1 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libpng
- Versions du logiciel
- < 1.6.54: Concernée
Aucun correctif publié
libpng1.6 Debian:12
- Versions du logiciel
- 1.6.39-2
- 1.6.39-2+deb12u1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.39-2+deb12u2
Mettez à jour vers 1.6.39-2+deb12u2
libpng1.6 Debian:13
- Versions du logiciel
- 1.6.48-1
- 1.6.48-1+deb13u1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.48-1+deb13u2
Mettez à jour vers 1.6.48-1+deb13u2
libpng1.6 Debian:14
- Versions du logiciel
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.54-1
Mettez à jour vers 1.6.54-1
libpng1.6 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- 1.6.20-2ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm3
Mettez à jour vers 1.6.20-2ubuntu0.1~esm3
libpng1.6 Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2
Mettez à jour vers 1.6.34-1ubuntu0.18.04.2+esm2
libpng1.6 Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2
Mettez à jour vers 1.6.37-2ubuntu0.1~esm2
libpng1.6 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.37-3ubuntu0.3
Mettez à jour vers 1.6.37-3ubuntu0.3
libpng1.6 Ubuntu:24.04:LTS
- Versions du logiciel
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.43-5ubuntu0.3
Mettez à jour vers 1.6.43-5ubuntu0.3
libpng1.6 Ubuntu:25.10
- Versions du logiciel
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- 1.6.50-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.50-1ubuntu0.3
Mettez à jour vers 1.6.50-1ubuntu0.3
Sources originales
- https://github.com/pnggroup/libpng/security/advisories/GHSA-mmq5-27w3-rxpp
- https://github.com/pnggroup/libpng/issues/778
- https://github.com/pnggroup/libpng/commit/218612ddd6b17944e21eda56caf8b4bf7779d1ea
- https://github.com/pnggroup/libpng/commit/e4f7ad4ea2
- https://nvd.nist.gov/vuln/detail/CVE-2026-22695