CVE-2026-22695
CVE-2026-22695 · LIBPNG has a heap buffer over-read in png_image_read_direct_scaled (regression from CVE-2025-65018 fix)
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From 1.6.51 to 1.6.53, there is a heap buffer over-read in the libpng simplified API function png_image_finish_read when processing interlaced 16-bit PNGs with 8-bit output format and non-minimal row stride. This is a regression introduced by the fix for CVE-2025-65018. This vulnerability is fixed in 1.6.54.
CVSS 6.1 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libpng
- Softwareversionen
- < 1.6.54: Betroffen
Keine Korrektur veröffentlicht
libpng1.6 Debian:12
- Softwareversionen
- 1.6.39-2
- 1.6.39-2+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.39-2+deb12u2
Auf 1.6.39-2+deb12u2 aktualisieren
libpng1.6 Debian:13
- Softwareversionen
- 1.6.48-1
- 1.6.48-1+deb13u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.48-1+deb13u2
Auf 1.6.48-1+deb13u2 aktualisieren
libpng1.6 Debian:14
- Softwareversionen
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.54-1
Auf 1.6.54-1 aktualisieren
libpng1.6 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- 1.6.20-2ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm3
Auf 1.6.20-2ubuntu0.1~esm3 aktualisieren
libpng1.6 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2
Auf 1.6.34-1ubuntu0.18.04.2+esm2 aktualisieren
libpng1.6 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2
Auf 1.6.37-2ubuntu0.1~esm2 aktualisieren
libpng1.6 Ubuntu:22.04:LTS
- Softwareversionen
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.37-3ubuntu0.3
Auf 1.6.37-3ubuntu0.3 aktualisieren
libpng1.6 Ubuntu:24.04:LTS
- Softwareversionen
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.43-5ubuntu0.3
Auf 1.6.43-5ubuntu0.3 aktualisieren
libpng1.6 Ubuntu:25.10
- Softwareversionen
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- 1.6.50-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.50-1ubuntu0.3
Auf 1.6.50-1ubuntu0.3 aktualisieren
Originalquellen
- https://github.com/pnggroup/libpng/security/advisories/GHSA-mmq5-27w3-rxpp
- https://github.com/pnggroup/libpng/issues/778
- https://github.com/pnggroup/libpng/commit/218612ddd6b17944e21eda56caf8b4bf7779d1ea
- https://github.com/pnggroup/libpng/commit/e4f7ad4ea2
- https://nvd.nist.gov/vuln/detail/CVE-2026-22695