p PatchFirst

CVE-2026-27601

CVE-2026-27601 · Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.

CVSS 8.2 · Élevée · EPSS 1,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • underscore

    Versions du logiciel
    • < 1.13.8: Concernée

    Aucun correctif publié

  • underscore Debian:12

    Versions du logiciel
    • 1.13.4~dfsg+~1.11.4-3
    • 1.13.7~dfsg+~1.13.0-1
    • 1.13.7~dfsg+~1.13.0-2
    • 1.13.7~dfsg+~1.13.0-3
    • 1.13.7~dfsg+~1.13.0-4
    • 1.13.7~dfsg+~1.13.0-5
    • 1.13.7~dfsg+~1.13.0-6
    • 1.13.8~dfsg+~1.13.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • underscore Debian:13

    Versions du logiciel
    • 1.13.4~dfsg+~1.11.4-3
    • 1.13.7~dfsg+~1.13.0-1
    • 1.13.7~dfsg+~1.13.0-2
    • 1.13.7~dfsg+~1.13.0-3
    • 1.13.7~dfsg+~1.13.0-4
    • 1.13.7~dfsg+~1.13.0-5
    • 1.13.7~dfsg+~1.13.0-6
    • 1.13.8~dfsg+~1.13.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • underscore Debian:14

    Versions du logiciel
    • 1.13.4~dfsg+~1.11.4-3
    • 1.13.7~dfsg+~1.13.0-1
    • 1.13.7~dfsg+~1.13.0-2
    • 1.13.7~dfsg+~1.13.0-3
    • 1.13.7~dfsg+~1.13.0-4
    • 1.13.7~dfsg+~1.13.0-5
    • 1.13.7~dfsg+~1.13.0-6
    Plages de versions concernées
    • ECOSYSTEM: < 1.13.8~dfsg+~1.13.0-1

    Mettez à jour vers 1.13.8~dfsg+~1.13.0-1

  • underscore npm

    Plages de versions concernées
    • SEMVER: < 1.13.8

    Mettez à jour vers 1.13.8

  • ruby-rails-assets-underscore Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.8.3+dfsg-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ruby-rails-assets-underscore Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.8.3+dfsg-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ruby-rails-assets-underscore Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.8.3+dfsg-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • ruby-rails-assets-underscore Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.8.3+dfsg-4
    • 1.8.3+dfsg-5
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →