p PatchFirst

CVE-2026-27601

CVE-2026-27601 · Underscore.js has unlimited recursion in _.flatten and _.isEqual, potential for DoS attack

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Underscore.js is a utility-belt library for JavaScript. Prior to 1.13.8, the _.flatten and _.isEqual functions use recursion without a depth limit. Under very specific conditions, detailed below, an attacker could exploit this in a Denial of Service (DoS) attack by triggering a stack overflow. Untrusted input must be used to create a recursive datastructure, for example using JSON.parse, with no enforced depth limit. The datastructure thus created must be passed to _.flatten or _.isEqual. In the case of _.flatten, the vulnerability can only be exploited if it is possible for a remote client to prepare a datastructure that consists of arrays at all levels AND if no finite depth limit is passed as the second argument to _.flatten. In the case of _.isEqual, the vulnerability can only be exploited if there exists a code path in which two distinct datastructures that were submitted by the same remote client are compared using _.isEqual. For example, if a client submits data that are stored in a database, and the same client can later submit another datastructure that is then compared to the data that were saved in the database previously, OR if a client submits a single request, but its data are parsed twice, creating two non-identical but equivalent datastructures that are then compared. Exceptions originating from the call to _.flatten or _.isEqual, as a result of a stack overflow, are not being caught. This vulnerability is fixed in 1.13.8.

CVSS 8.2 · Hoch · EPSS 1,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • underscore

    Softwareversionen
    • < 1.13.8: Betroffen

    Keine Korrektur veröffentlicht

  • underscore Debian:12

    Softwareversionen
    • 1.13.4~dfsg+~1.11.4-3
    • 1.13.7~dfsg+~1.13.0-1
    • 1.13.7~dfsg+~1.13.0-2
    • 1.13.7~dfsg+~1.13.0-3
    • 1.13.7~dfsg+~1.13.0-4
    • 1.13.7~dfsg+~1.13.0-5
    • 1.13.7~dfsg+~1.13.0-6
    • 1.13.8~dfsg+~1.13.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • underscore Debian:13

    Softwareversionen
    • 1.13.4~dfsg+~1.11.4-3
    • 1.13.7~dfsg+~1.13.0-1
    • 1.13.7~dfsg+~1.13.0-2
    • 1.13.7~dfsg+~1.13.0-3
    • 1.13.7~dfsg+~1.13.0-4
    • 1.13.7~dfsg+~1.13.0-5
    • 1.13.7~dfsg+~1.13.0-6
    • 1.13.8~dfsg+~1.13.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • underscore Debian:14

    Softwareversionen
    • 1.13.4~dfsg+~1.11.4-3
    • 1.13.7~dfsg+~1.13.0-1
    • 1.13.7~dfsg+~1.13.0-2
    • 1.13.7~dfsg+~1.13.0-3
    • 1.13.7~dfsg+~1.13.0-4
    • 1.13.7~dfsg+~1.13.0-5
    • 1.13.7~dfsg+~1.13.0-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.13.8~dfsg+~1.13.0-1

    Auf 1.13.8~dfsg+~1.13.0-1 aktualisieren

  • underscore npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.13.8

    Auf 1.13.8 aktualisieren

  • ruby-rails-assets-underscore Ubuntu:18.04:LTS

    Softwareversionen
    • 1.8.3+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-rails-assets-underscore Ubuntu:20.04:LTS

    Softwareversionen
    • 1.8.3+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-rails-assets-underscore Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.3+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby-rails-assets-underscore Ubuntu:24.04:LTS

    Softwareversionen
    • 1.8.3+dfsg-4
    • 1.8.3+dfsg-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →