CVE-2026-32700
CVE-2026-32700 · Devise has a confirmable "change email" race condition that permits user to confirm email they have no access to
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Devise is an authentication solution for Rails based on Warden. Prior to version 5.0.3, a race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own. This affects any Devise application using the `reconfirmable` option (the default when using Confirmable with email changes). By sending two concurrent email change requests, an attacker can desynchronize the `confirmation_token` and `unconfirmed_email` fields. The confirmation token is sent to an email the attacker controls, but the `unconfirmed_email` in the database points to a victim's email address. When the attacker uses the token, the victim's email is confirmed on the attacker's account. This is patched in Devise v5.0.3. Users should upgrade as soon as possible. As a workaround, applications can override a specific method from Devise models to force `unconfirmed_email` to be persisted when unchanged. Note that Mongoid does not seem to respect that `will_change!` should force the attribute to be persisted, even if it did not really change, so the user might have to implement a workaround similar to Devise by setting `changed_attributes["unconfirmed_email"] = nil` as well.
CVSS 6.0 · Moyenne · EPSS 0,3%
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
devise
- Versions du logiciel
- < 5.0.3: Concernée
Aucun correctif publié
ruby-devise Debian:12
- Versions du logiciel
- 4.8.1-1
- 4.9.2-1
- 4.9.3-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:16.04:LTS
- Versions du logiciel
- 3.5.1-1
- 3.5.2-1
- 3.5.2-2
- 3.5.2-3
- 3.5.6-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:18.04:LTS
- Versions du logiciel
- 4.2.0-1
- 4.3.0-1
- 4.4.3-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:20.04:LTS
- Versions du logiciel
- 4.5.0-3
- 4.6.2-2
- 4.7.1-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:22.04:LTS
- Versions du logiciel
- 4.7.3-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
ruby-devise Ubuntu:24.04:LTS
- Versions du logiciel
- 4.8.1-1
- 4.9.2-1
- 4.9.3-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/heartcombo/devise/security/advisories/GHSA-57hq-95w6-v4fc
- https://github.com/heartcombo/devise/issues/5783
- https://github.com/heartcombo/devise/pull/5784
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/devise/GHSA-57hq-95w6-v4fc.yml
- https://nvd.nist.gov/vuln/detail/CVE-2026-32700