p PatchFirst

CVE-2026-32700

CVE-2026-32700 · Devise has a confirmable "change email" race condition that permits user to confirm email they have no access to

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Devise is an authentication solution for Rails based on Warden. Prior to version 5.0.3, a race condition in Devise's Confirmable module allows an attacker to confirm an email address they do not own. This affects any Devise application using the `reconfirmable` option (the default when using Confirmable with email changes). By sending two concurrent email change requests, an attacker can desynchronize the `confirmation_token` and `unconfirmed_email` fields. The confirmation token is sent to an email the attacker controls, but the `unconfirmed_email` in the database points to a victim's email address. When the attacker uses the token, the victim's email is confirmed on the attacker's account. This is patched in Devise v5.0.3. Users should upgrade as soon as possible. As a workaround, applications can override a specific method from Devise models to force `unconfirmed_email` to be persisted when unchanged. Note that Mongoid does not seem to respect that `will_change!` should force the attribute to be persisted, even if it did not really change, so the user might have to implement a workaround similar to Devise by setting `changed_attributes["unconfirmed_email"] = nil` as well.

CVSS 6.0 · Media · EPSS 0,3%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • devise

    Versiones
    • < 5.0.3: Afectada

    Sin corrección publicada

  • ruby-devise Debian:12

    Versiones
    • 4.8.1-1
    • 4.9.2-1
    • 4.9.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:16.04:LTS

    Versiones
    • 3.5.1-1
    • 3.5.2-1
    • 3.5.2-2
    • 3.5.2-3
    • 3.5.6-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:18.04:LTS

    Versiones
    • 4.2.0-1
    • 4.3.0-1
    • 4.4.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:20.04:LTS

    Versiones
    • 4.5.0-3
    • 4.6.2-2
    • 4.7.1-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:22.04:LTS

    Versiones
    • 4.7.3-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby-devise Ubuntu:24.04:LTS

    Versiones
    • 4.8.1-1
    • 4.9.2-1
    • 4.9.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →