p PatchFirst

CVE-2026-33019

CVE-2026-33019 · libsixel: Integer overflow leads to Out-of-bounds Read in img2sixel

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow leading to an out-of-bounds heap read in the --crop option handling of img2sixel, where positive coordinates up to INT_MAX are accepted without overflow-safe bounds checking. In sixel_encoder_do_clip(), the expression clip_w + clip_x overflows to a large negative value when clip_x is INT_MAX, causing the bounds guard to be skipped entirely, and the unclamped coordinate is passed through sixel_frame_clip() to clip(), which computes a source pointer far beyond the image buffer and passes it to memmove(). An attacker supplying a specially crafted crop argument with any valid image can trigger an out-of-bounds read in the heap, resulting in a reliable crash and potential information disclosure. This issue has been fixed in version 1.8.7-r1.

CVSS 7.1 · Élevée · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • libsixel

    Versions du logiciel
    • < 1.8.7-r1: Concernée

    Aucun correctif publié

  • libsixel Debian:12

    Versions du logiciel
    • 1.10.3-3
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    • 1:1.8.7-r2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Debian:13

    Versions du logiciel
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    • 1:1.8.7-r2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Debian:14

    Versions du logiciel
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    Plages de versions concernées
    • ECOSYSTEM: < 1:1.8.7-r2-1

    Mettez à jour vers 1:1.8.7-r2-1

  • libsixel Ubuntu:16.04:LTS

    Versions du logiciel
    • 1.4.2-1
    • 1.5.2-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.5.2-2
    • 1.7.3-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.8.2-1
    • 1.8.2-2.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:22.04:LTS

    Versions du logiciel
    • 1.8.6-2
    • 1.10.3-2
    • 1.10.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:24.04:LTS

    Versions du logiciel
    • 1.10.3-3
    • 1.10.3-3build1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:25.10

    Versions du logiciel
    • 1.10.5-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:26.10

    Versions du logiciel
    • 1.10.5-1build1
    • 1:1.8.7-r2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • libsixel Ubuntu:26.04:LTS

    Versions du logiciel
    • 1.10.5-1
    • 1.10.5-1build1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →