CVE-2026-33019
CVE-2026-33019 · libsixel: Integer overflow leads to Out-of-bounds Read in img2sixel
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow leading to an out-of-bounds heap read in the --crop option handling of img2sixel, where positive coordinates up to INT_MAX are accepted without overflow-safe bounds checking. In sixel_encoder_do_clip(), the expression clip_w + clip_x overflows to a large negative value when clip_x is INT_MAX, causing the bounds guard to be skipped entirely, and the unclamped coordinate is passed through sixel_frame_clip() to clip(), which computes a source pointer far beyond the image buffer and passes it to memmove(). An attacker supplying a specially crafted crop argument with any valid image can trigger an out-of-bounds read in the heap, resulting in a reliable crash and potential information disclosure. This issue has been fixed in version 1.8.7-r1.
CVSS 7.1 · Hoch · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libsixel
- Softwareversionen
- < 1.8.7-r1: Betroffen
Keine Korrektur veröffentlicht
libsixel Debian:12
- Softwareversionen
- 1.10.3-3
- 1.10.5-1
- 1:1.8.7-1
- 1:1.8.7-2
- 1:1.8.7-3
- 1:1.8.7-4
- 1:1.8.7-5
- 1:1.8.7-6
- 1:1.8.7-r2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Debian:13
- Softwareversionen
- 1.10.5-1
- 1:1.8.7-1
- 1:1.8.7-2
- 1:1.8.7-3
- 1:1.8.7-4
- 1:1.8.7-5
- 1:1.8.7-6
- 1:1.8.7-r2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Debian:14
- Softwareversionen
- 1.10.5-1
- 1:1.8.7-1
- 1:1.8.7-2
- 1:1.8.7-3
- 1:1.8.7-4
- 1:1.8.7-5
- 1:1.8.7-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:1.8.7-r2-1
Auf 1:1.8.7-r2-1 aktualisieren
libsixel Ubuntu:16.04:LTS
- Softwareversionen
- 1.4.2-1
- 1.5.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:18.04:LTS
- Softwareversionen
- 1.5.2-2
- 1.7.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:20.04:LTS
- Softwareversionen
- 1.8.2-1
- 1.8.2-2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:22.04:LTS
- Softwareversionen
- 1.8.6-2
- 1.10.3-2
- 1.10.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:24.04:LTS
- Softwareversionen
- 1.10.3-3
- 1.10.3-3build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:25.10
- Softwareversionen
- 1.10.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:26.10
- Softwareversionen
- 1.10.5-1build1
- 1:1.8.7-r2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libsixel Ubuntu:26.04:LTS
- Softwareversionen
- 1.10.5-1
- 1.10.5-1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht