CVE-2026-34380
CVE-2026-34380 · OpenEXR has a signed integer overflow (undefined behavior) in undo_pxr24_impl may allow bounds-check bypass in PXR24 decompression
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a signed integer overflow exists in undo_pxr24_impl() in src/lib/OpenEXRCore/internal_pxr24.c at line 377. The expression (uint64_t)(w * 3) computes w * 3 as a signed 32-bit integer before casting to uint64_t. When w is large, this multiplication constitutes undefined behavior under the C standard. On tested builds (clang/gcc without sanitizers), two's-complement wraparound commonly occurs, and for specific values of w the wrapped result is a small positive integer, which may allow the subsequent bounds check to pass incorrectly. If the check is bypassed, the decoding loop proceeds to write pixel data through dout, potentially extending far beyond the allocated output buffer. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.
CVSS 5.9 · Moyenne · EPSS 0,3% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
openexr
- Versions du logiciel
- >= 3.2.0, < 3.2.7: Concernée
- >= 3.3.0, < 3.3.9: Concernée
- >= 3.4.0, < 3.4.9: Concernée
Aucun correctif publié
openexr Debian:12
- Versions du logiciel
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Debian:13
- Versions du logiciel
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Debian:14
- Versions du logiciel
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Plages de versions concernées
- ECOSYSTEM: < 3.4.14-0.1
Mettez à jour vers 3.4.14-0.1
openexr Ubuntu:Pro:24.04:LTS
- Versions du logiciel
- 3.1.5-5.1
- 3.1.5-5.1build1
- 3.1.5-5.1build2
- 3.1.5-5.1build3
- Plages de versions concernées
- ECOSYSTEM: < 3.1.5-5.1ubuntu0.1~esm1
Mettez à jour vers 3.1.5-5.1ubuntu0.1~esm1
openexr Ubuntu:25.10
- Versions du logiciel
- 3.1.13-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Ubuntu:26.10
- Versions du logiciel
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
openexr Ubuntu:Pro:26.04:LTS
- Versions du logiciel
- 3.1.13-2
- 3.1.13-2build1
- Plages de versions concernées
- ECOSYSTEM: < 3.1.13-2ubuntu0.26.04.1~esm1
Mettez à jour vers 3.1.13-2ubuntu0.26.04.1~esm1
Sources originales
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-q3v8-hw4m-59w5
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.7
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.9
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.9
- https://nvd.nist.gov/vuln/detail/CVE-2026-34380