p PatchFirst

CVE-2026-34380

CVE-2026-34380 · OpenEXR has a signed integer overflow (undefined behavior) in undo_pxr24_impl may allow bounds-check bypass in PXR24 decompression

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, a signed integer overflow exists in undo_pxr24_impl() in src/lib/OpenEXRCore/internal_pxr24.c at line 377. The expression (uint64_t)(w * 3) computes w * 3 as a signed 32-bit integer before casting to uint64_t. When w is large, this multiplication constitutes undefined behavior under the C standard. On tested builds (clang/gcc without sanitizers), two's-complement wraparound commonly occurs, and for specific values of w the wrapped result is a small positive integer, which may allow the subsequent bounds check to pass incorrectly. If the check is bypassed, the decoding loop proceeds to write pixel data through dout, potentially extending far beyond the allocated output buffer. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.

CVSS 5.9 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • openexr

    Softwareversionen
    • >= 3.2.0, < 3.2.7: Betroffen
    • >= 3.3.0, < 3.3.9: Betroffen
    • >= 3.4.0, < 3.4.9: Betroffen

    Keine Korrektur veröffentlicht

  • openexr Debian:12

    Softwareversionen
    • 3.1.13-1
    • 3.1.13-2
    • 3.1.5-5
    • 3.1.5-5.1
    • 3.1.5-5.1+hurd.1
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.16+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    • 3.5.2+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Debian:13

    Softwareversionen
    • 3.1.13-2
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.16+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    • 3.5.2+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Debian:14

    Softwareversionen
    • 3.1.13-2
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.14-0.1

    Auf 3.4.14-0.1 aktualisieren

  • openexr Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 3.1.5-5.1
    • 3.1.5-5.1build1
    • 3.1.5-5.1build2
    • 3.1.5-5.1build3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.5-5.1ubuntu0.1~esm1

    Auf 3.1.5-5.1ubuntu0.1~esm1 aktualisieren

  • openexr Ubuntu:25.10

    Softwareversionen
    • 3.1.13-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:26.10

    Softwareversionen
    • 3.1.13-2build1
    • 3.4.6+ds-4ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openexr Ubuntu:Pro:26.04:LTS

    Softwareversionen
    • 3.1.13-2
    • 3.1.13-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.13-2ubuntu0.26.04.1~esm1

    Auf 3.1.13-2ubuntu0.26.04.1~esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →