CVE-2026-50169
CVE-2026-50169 · Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.
CVSS 5.7 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
angular
- Versions du logiciel
- >= 22.0.0-next.0, < 22.0.0-rc.2: Concernée
- >= 21.0.0-next.0, < 21.2.15: Concernée
- >= 20.0.0-next.0, < 20.3.22: Concernée
- >= 19.0.0-next.0, < 19.2.23: Concernée
- <= 18.2.14: Concernée
Aucun correctif publié
angular.js Debian:12
- Versions du logiciel
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Debian:13
- Versions du logiciel
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
@angular/service-worker npm
- Plages de versions concernées
- SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2
Mettez à jour vers 22.0.0-rc.2
@angular/service-worker npm
- Plages de versions concernées
- SEMVER: ≥ 20.0.0-next.0, < 20.3.22
Mettez à jour vers 20.3.22
@angular/service-worker npm
- Plages de versions concernées
- SEMVER: ≥ 19.0.0-next.0, < 19.2.23
Mettez à jour vers 19.2.23
@angular/service-worker npm
- Plages de versions concernées
- SEMVER: ≤ 18.2.14
Aucun correctif publié
@angular/service-worker npm
- Plages de versions concernées
- SEMVER: ≥ 21.0.0-next.0, < 21.2.15
Mettez à jour vers 21.2.15
angular.js Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:22.04:LTS
- Versions du logiciel
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:24.04:LTS
- Versions du logiciel
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:25.10
- Versions du logiciel
- 1.8.3-1
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:26.10
- Versions du logiciel
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
angular.js Ubuntu:26.04:LTS
- Versions du logiciel
- 1.8.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié