CVE-2026-50169
CVE-2026-50169 · Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.
CVSS 5.7 · Mittel · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
angular
- Softwareversionen
- >= 22.0.0-next.0, < 22.0.0-rc.2: Betroffen
- >= 21.0.0-next.0, < 21.2.15: Betroffen
- >= 20.0.0-next.0, < 20.3.22: Betroffen
- >= 19.0.0-next.0, < 19.2.23: Betroffen
- <= 18.2.14: Betroffen
Keine Korrektur veröffentlicht
angular.js Debian:12
- Softwareversionen
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Debian:13
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
@angular/service-worker npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2
Auf 22.0.0-rc.2 aktualisieren
@angular/service-worker npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 20.0.0-next.0, < 20.3.22
Auf 20.3.22 aktualisieren
@angular/service-worker npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 19.0.0-next.0, < 19.2.23
Auf 19.2.23 aktualisieren
@angular/service-worker npm
- Betroffene Versionsbereiche
- SEMVER: ≤ 18.2.14
Keine Korrektur veröffentlicht
@angular/service-worker npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 21.0.0-next.0, < 21.2.15
Auf 21.2.15 aktualisieren
angular.js Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:22.04:LTS
- Softwareversionen
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:24.04:LTS
- Softwareversionen
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:25.10
- Softwareversionen
- 1.8.3-1
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:26.10
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
angular.js Ubuntu:26.04:LTS
- Softwareversionen
- 1.8.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht