p PatchFirst

CVE-2026-52817

CVE-2026-52817 · Linuxfabrik Monitoring Plugins Sudoers: /usr/bin/apt-get arguments allow privilege escalation

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Linuxfabrik Monitoring Plugins provides monitoring plugins for Icinga, Nagios, and related systems. Prior to version 5.1.0, the shipped assets/sudoers/Debian.sudoers policy allowed the nagios or icinga account to execute /usr/bin/apt-get as root without restricting its arguments. An attacker who already controls that monitoring account can supply the APT::Update::Pre-Invoke option to execute an arbitrary command while apt-get runs with root privileges, resulting in a root shell and complete compromise of the host. The vulnerable rule supports the check-plugins/deb-updates/deb-updates plugin, but it authorized arbitrary apt-get argument sequences rather than only the required apt-get update --quiet 2 command. This issue is fixed in version 5.1.0.

CVSS 7.0 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • monitoring-plugins

    Versions du logiciel
    • < 5.1.0: Concernée

    Aucun correctif publié

  • linuxfabrik-lib PyPI

    Versions du logiciel
    • 2.0.0.0
    • 2.0.0.7
    • 2.1.0.0
    • 2.1.0.4
    • 2.1.1.15
    • 2.1.1.5
    • 2.1.1.7
    • 2.2.0
    • 2.2.1
    • 2.3.0
    • 2.4.0
    • 3.0.0
    • 3.1.0
    • 3.1.1
    • 3.2.0
    • 3.3.0
    • 3.4.0
    • 3.4.1
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 4.4.0
    • 5.0.0
    Plages de versions concernées
    • ECOSYSTEM: < 5.1.0

    Mettez à jour vers 5.1.0

Sources originales

Vérifiez votre serveur →