CVE-2026-52817
CVE-2026-52817 · Linuxfabrik Monitoring Plugins Sudoers: /usr/bin/apt-get arguments allow privilege escalation
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Linuxfabrik Monitoring Plugins provides monitoring plugins for Icinga, Nagios, and related systems. Prior to version 5.1.0, the shipped assets/sudoers/Debian.sudoers policy allowed the nagios or icinga account to execute /usr/bin/apt-get as root without restricting its arguments. An attacker who already controls that monitoring account can supply the APT::Update::Pre-Invoke option to execute an arbitrary command while apt-get runs with root privileges, resulting in a root shell and complete compromise of the host. The vulnerable rule supports the check-plugins/deb-updates/deb-updates plugin, but it authorized arbitrary apt-get argument sequences rather than only the required apt-get update --quiet 2 command. This issue is fixed in version 5.1.0.
CVSS 7.0 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
monitoring-plugins
- Softwareversionen
- < 5.1.0: Betroffen
Keine Korrektur veröffentlicht
linuxfabrik-lib PyPI
- Softwareversionen
- 2.0.0.0
- 2.0.0.7
- 2.1.0.0
- 2.1.0.4
- 2.1.1.15
- 2.1.1.5
- 2.1.1.7
- 2.2.0
- 2.2.1
- 2.3.0
- 2.4.0
- 3.0.0
- 3.1.0
- 3.1.1
- 3.2.0
- 3.3.0
- 3.4.0
- 3.4.1
- 4.0.0
- 4.0.1
- 4.0.2
- 4.1.0
- 4.2.0
- 4.3.0
- 4.4.0
- 5.0.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.1.0
Auf 5.1.0 aktualisieren
Originalquellen
- https://github.com/Linuxfabrik/monitoring-plugins/security/advisories/GHSA-8w6w-23mq-h8rg
- https://github.com/Linuxfabrik/monitoring-plugins/commit/694b5daeebadc9a51428f3de1acff7b1f737642f
- https://github.com/Linuxfabrik/monitoring-plugins/blob/main/CHANGELOG.md#v510---2026-05-30
- https://github.com/Linuxfabrik/monitoring-plugins/releases/tag/v5.1.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-52817