CVE-2026-53925
CVE-2026-53925 · Glances: Arbitrary file write and command execution via `secure_popen` redirection and chaining operators in AMP command configuration
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Glances is an open-source system cross-platform monitoring tool. From 4.0.8 until 4.5.5, the secure_popen() function in glances/secure.py interprets > (file redirection), | (pipe), and && (command chaining) operators in command strings. These operators are applied without any validation on the target file path, piped command, or chained command. When Application Monitoring Process (AMP) modules load their command or service_cmd configuration values from glances.conf, those values are passed directly to secure_popen() with no sanitization. This allows an attacker who can modify the Glances configuration file to write arbitrary content to arbitrary filesystem paths (via >), chain arbitrary commands (via &&), or pipe command output to arbitrary programs (via |). This vulnerability is fixed in 4.5.5.
CVSS 7.8 · Élevée · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
glances
- Versions du logiciel
- >= 4.0.8, < 4.5.5: Concernée
Aucun correctif publié
glances Debian:12
- Versions du logiciel
- 3.3.1.1+dfsg-1
- 3.4.0.3+dfsg-1
- 4.0.5+dfsg-1
- 4.1.2.1+dfsg-1
- 4.2.1+dfsg-1
- 4.3.0.8+dfsg-1
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- 4.5.5+dfsg-1
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.8+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Debian:13
- Versions du logiciel
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- 4.5.5+dfsg-1
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.8+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Debian:14
- Versions du logiciel
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: < 4.5.5+dfsg-1
Mettez à jour vers 4.5.5+dfsg-1
glances PyPI
- Versions du logiciel
- 4.0.8
- 4.1.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.1
- 4.3.0
- 4.3.0.1
- 4.3.0.3
- 4.3.0.4
- 4.3.0.5
- 4.3.0.6
- 4.3.0.7
- 4.3.0.8
- 4.3.1
- 4.3.2
- 4.3.3
- 4.4.0
- 4.4.1
- 4.5.0
- 4.5.0.1
- 4.5.0.2
- 4.5.0.3
- 4.5.0.4
- 4.5.0.5
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- Plages de versions concernées
- ECOSYSTEM: ≥ 4.0.8, < 4.5.5
Mettez à jour vers 4.5.5
glances Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2.3-1build1
- 2.3-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 2.10-2
- 2.11.1-1
- 2.11.1-2
- 2.11.1-3
- 2.11.1-3ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 3.1.0-1
- 3.1.1-1
- 3.1.3-1
- 3.1.3-1ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Ubuntu:22.04:LTS
- Versions du logiciel
- 3.1.5-1
- 3.2.3.1+dfsg-1
- 3.2.4.2+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Ubuntu:24.04:LTS
- Versions du logiciel
- 3.4.0.3+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Ubuntu:25.10
- Versions du logiciel
- 4.3.0.8+dfsg-1
- 4.3.1+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
glances Ubuntu:26.04:LTS
- Versions du logiciel
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié