CVE-2026-53925
CVE-2026-53925 · Glances: Arbitrary file write and command execution via `secure_popen` redirection and chaining operators in AMP command configuration
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Glances is an open-source system cross-platform monitoring tool. From 4.0.8 until 4.5.5, the secure_popen() function in glances/secure.py interprets > (file redirection), | (pipe), and && (command chaining) operators in command strings. These operators are applied without any validation on the target file path, piped command, or chained command. When Application Monitoring Process (AMP) modules load their command or service_cmd configuration values from glances.conf, those values are passed directly to secure_popen() with no sanitization. This allows an attacker who can modify the Glances configuration file to write arbitrary content to arbitrary filesystem paths (via >), chain arbitrary commands (via &&), or pipe command output to arbitrary programs (via |). This vulnerability is fixed in 4.5.5.
CVSS 7.8 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
glances
- Softwareversionen
- >= 4.0.8, < 4.5.5: Betroffen
Keine Korrektur veröffentlicht
glances Debian:12
- Softwareversionen
- 3.3.1.1+dfsg-1
- 3.4.0.3+dfsg-1
- 4.0.5+dfsg-1
- 4.1.2.1+dfsg-1
- 4.2.1+dfsg-1
- 4.3.0.8+dfsg-1
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- 4.5.5+dfsg-1
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.8+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Debian:13
- Softwareversionen
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- 4.5.5+dfsg-1
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.8+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Debian:14
- Softwareversionen
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- 4.5.1+dfsg-1
- 4.5.2+dfsg-1
- 4.5.3.2+dfsg-1
- 4.5.4+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.5.5+dfsg-1
Auf 4.5.5+dfsg-1 aktualisieren
glances PyPI
- Softwareversionen
- 4.0.8
- 4.1.0
- 4.1.1
- 4.1.2
- 4.2.0
- 4.2.1
- 4.3.0
- 4.3.0.1
- 4.3.0.3
- 4.3.0.4
- 4.3.0.5
- 4.3.0.6
- 4.3.0.7
- 4.3.0.8
- 4.3.1
- 4.3.2
- 4.3.3
- 4.4.0
- 4.4.1
- 4.5.0
- 4.5.0.1
- 4.5.0.2
- 4.5.0.3
- 4.5.0.4
- 4.5.0.5
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.0.8, < 4.5.5
Auf 4.5.5 aktualisieren
glances Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.3-1build1
- 2.3-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.10-2
- 2.11.1-1
- 2.11.1-2
- 2.11.1-3
- 2.11.1-3ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 3.1.0-1
- 3.1.1-1
- 3.1.3-1
- 3.1.3-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Ubuntu:22.04:LTS
- Softwareversionen
- 3.1.5-1
- 3.2.3.1+dfsg-1
- 3.2.4.2+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Ubuntu:24.04:LTS
- Softwareversionen
- 3.4.0.3+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Ubuntu:25.10
- Softwareversionen
- 4.3.0.8+dfsg-1
- 4.3.1+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
glances Ubuntu:26.04:LTS
- Softwareversionen
- 4.3.1+dfsg-1
- 4.3.3+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht