CVE-2026-73258
CVE-2026-73258 · Mongoose: Multipart boundary/header scan logic error in mg_http_next_multipart
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.
CVSS 6.5 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
mongoose
- Versions du logiciel
- < 7.22: Concernée
Aucun correctif publié
mongoose Debian:14
- Versions du logiciel
- 7.21+ds-1
- 7.21+ds-1~bpo13+1
- 7.21+ds-2
- 7.22+ds-1~bpo13+1
- Plages de versions concernées
- ECOSYSTEM: < 7.22+ds-1
Mettez à jour vers 7.22+ds-1
mongoose Ubuntu:26.10
- Versions du logiciel
- 7.21+ds-1
- 7.21+ds-2
- 7.22+ds-1
- 7.23+ds-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/cesanta/mongoose/security/advisories/GHSA-cc55-8v3r-59p8
- https://github.com/cesanta/mongoose/pull/3611
- https://github.com/cesanta/mongoose/commit/a9df523f76f43a38bd53b4232b9cfd4c16869e71
- https://github.com/cesanta/mongoose/releases/tag/7.22
- https://nvd.nist.gov/vuln/detail/CVE-2026-73258