p PatchFirst

CVE-2026-73258

CVE-2026-73258 · Mongoose: Multipart boundary/header scan logic error in mg_http_next_multipart

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Mongoose is an embedded web server and network library. Prior to 7.22, a remote attacker can place a lone carriage return or line feed in multipart input processed by mg_http_next_multipart() in src/http.c. The loops comparing s[b] and s[b + 1], and s[h2] and s[h2 + 1], use an incorrect AND condition and stop when either character resembles part of a CRLF terminator. This truncates headers, filenames, or boundaries and can cause an application to accept dangerous content after seeing a misleading Content-Type value. This issue is fixed in version 7.22.

CVSS 6.5 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mongoose

    Versions
    • < 7.22: Affected

    No fix published

  • mongoose Debian:14

    Versions
    • 7.21+ds-1
    • 7.21+ds-1~bpo13+1
    • 7.21+ds-2
    • 7.22+ds-1~bpo13+1
    Affected ranges
    • ECOSYSTEM: < 7.22+ds-1

    Update to 7.22+ds-1

  • mongoose Ubuntu:26.10

    Versions
    • 7.21+ds-1
    • 7.21+ds-2
    • 7.22+ds-1
    • 7.23+ds-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →