p PatchFirst

CVE-2026-75857

CVE-2026-75857 · CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

CVSS 7.3 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • codewhale

    Versions du logiciel
    • ≥ 0.3.10, ≤ 0.8.41: Concernée (semver)

    Aucun correctif publié

  • codewhale

    Versions du logiciel
    • ≥ 0.3.10, < 0.8.41: Concernée (semver)
    • 0.8.41: Non concernée (semver)

    Mettez à jour vers 0.8.41

  • codewhale

    Versions du logiciel
    • ≥ 0.8.41, < 0.8.64: Concernée (semver)
    • 0.8.64: Non concernée (semver)

    Mettez à jour vers 0.8.64

  • deepseek-tui crates.io

    Plages de versions concernées
    • SEMVER: ≥ 0.3.10, ≤ 0.8.41

    Aucun correctif publié

  • deepseek-tui npm

    Plages de versions concernées
    • SEMVER: ≥ 0.3.10, < 0.8.41

    Mettez à jour vers 0.8.41

  • codewhale-tui crates.io

    Plages de versions concernées
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Mettez à jour vers 0.8.64

  • codewhale npm

    Plages de versions concernées
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Mettez à jour vers 0.8.64

Sources originales

Vérifiez votre serveur →