p PatchFirst

CVE-2026-75857

CVE-2026-75857 · CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

CVSS 7.3 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • codewhale

    Softwareversionen
    • ≥ 0.3.10, ≤ 0.8.41: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • codewhale

    Softwareversionen
    • ≥ 0.3.10, < 0.8.41: Betroffen (semver)
    • 0.8.41: Nicht betroffen (semver)

    Auf 0.8.41 aktualisieren

  • codewhale

    Softwareversionen
    • ≥ 0.8.41, < 0.8.64: Betroffen (semver)
    • 0.8.64: Nicht betroffen (semver)

    Auf 0.8.64 aktualisieren

  • deepseek-tui crates.io

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.3.10, ≤ 0.8.41

    Keine Korrektur veröffentlicht

  • deepseek-tui npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.3.10, < 0.8.41

    Auf 0.8.41 aktualisieren

  • codewhale-tui crates.io

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Auf 0.8.64 aktualisieren

  • codewhale npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.8.41, < 0.8.64

    Auf 0.8.64 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →