CVE-2026-75931
CVE-2026-75931 · fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
fast-uri is a URI parser for Node.js. It canonicalizes a host to its ASCII form only when the input carries an explicit scheme, so a scheme-relative reference such as a host preceded by two slashes is returned with its host verbatim and no error set. As a result fast-uri's own entry points disagree with each other: parse, resolve, normalize, and equal can yield different hosts for the same input depending only on whether a scheme is written out, and equal can return opposite verdicts for the same pair of hosts. An application that extracts a host with fast-uri to check it against a policy list and then resolves the same reference can make its decision on one host while the destination is another, enabling host confusion and policy bypass. The affected versions are 2.4.2 up to but not including 2.4.5, 3.1.3 up to but not including 3.1.6, and 4.0.1 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which canonicalize the host consistently across the resolve path. Users should upgrade to a patched version.
CVSS 7.5 · Élevée · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
fast-uri
- Versions du logiciel
- ≥ 2.4.2, < 2.4.5: Concernée (semver)
- 2.4.5: Non concernée (semver)
- ≥ 3.1.3, < 3.1.6: Concernée (semver)
- 3.1.6: Non concernée (semver)
- ≥ 4.0.1, < 4.1.3: Concernée (semver)
- 4.1.3: Non concernée (semver)
Mettez à jour vers 2.4.5; Mettez à jour vers 3.1.6; Mettez à jour vers 4.1.3
node-ajv Debian:13
- Versions du logiciel
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- 8.20.0~ds+~cs7.1.4-1
- 8.20.0~ds+~cs7.1.5-1
- 8.20.0~ds+~cs7.1.6-1
- 8.20.0~ds+~cs7.1.6-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-ajv Debian:14
- Versions du logiciel
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- Plages de versions concernées
- ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1
Mettez à jour vers 8.20.0~ds+~cs7.1.4-1
fast-uri npm
- Plages de versions concernées
- SEMVER: ≥ 2.4.2, < 2.4.5
Mettez à jour vers 2.4.5
fast-uri npm
- Plages de versions concernées
- SEMVER: ≥ 3.1.3, < 3.1.6
Mettez à jour vers 3.1.6
fast-uri npm
- Plages de versions concernées
- SEMVER: ≥ 4.0.1, < 4.1.3
Mettez à jour vers 4.1.3
node-ajv Ubuntu:18.04:LTS
- Versions du logiciel
- 5.0.0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-ajv Ubuntu:20.04:LTS
- Versions du logiciel
- 6.10.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-ajv Ubuntu:22.04:LTS
- Versions du logiciel
- 6.12.6-2
- 6.12.6-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-ajv Ubuntu:24.04:LTS
- Versions du logiciel
- 6.12.6-3
- 8.12.0~ds+~2.1.1-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-ajv Ubuntu:26.10
- Versions du logiciel
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
node-ajv Ubuntu:26.04:LTS
- Versions du logiciel
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié