CVE-2026-75931
CVE-2026-75931 · fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
fast-uri is a URI parser for Node.js. It canonicalizes a host to its ASCII form only when the input carries an explicit scheme, so a scheme-relative reference such as a host preceded by two slashes is returned with its host verbatim and no error set. As a result fast-uri's own entry points disagree with each other: parse, resolve, normalize, and equal can yield different hosts for the same input depending only on whether a scheme is written out, and equal can return opposite verdicts for the same pair of hosts. An application that extracts a host with fast-uri to check it against a policy list and then resolves the same reference can make its decision on one host while the destination is another, enabling host confusion and policy bypass. The affected versions are 2.4.2 up to but not including 2.4.5, 3.1.3 up to but not including 3.1.6, and 4.0.1 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which canonicalize the host consistently across the resolve path. Users should upgrade to a patched version.
CVSS 7.5 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
fast-uri
- Softwareversionen
- ≥ 2.4.2, < 2.4.5: Betroffen (semver)
- 2.4.5: Nicht betroffen (semver)
- ≥ 3.1.3, < 3.1.6: Betroffen (semver)
- 3.1.6: Nicht betroffen (semver)
- ≥ 4.0.1, < 4.1.3: Betroffen (semver)
- 4.1.3: Nicht betroffen (semver)
Auf 2.4.5 aktualisieren; Auf 3.1.6 aktualisieren; Auf 4.1.3 aktualisieren
node-ajv Debian:13
- Softwareversionen
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- 8.20.0~ds+~cs7.1.4-1
- 8.20.0~ds+~cs7.1.5-1
- 8.20.0~ds+~cs7.1.6-1
- 8.20.0~ds+~cs7.1.6-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ajv Debian:14
- Softwareversionen
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-1
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-3
- 8.17.1~ds+~3.0.1+~3.1.0-4
- 8.18.0~ds+~cs6.1.1-1
- 8.18.0~ds+~cs6.1.1-2
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-2
- 8.20.0~ds+~cs7.1.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1
Auf 8.20.0~ds+~cs7.1.4-1 aktualisieren
fast-uri npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.4.2, < 2.4.5
Auf 2.4.5 aktualisieren
fast-uri npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.1.3, < 3.1.6
Auf 3.1.6 aktualisieren
fast-uri npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.1, < 4.1.3
Auf 4.1.3 aktualisieren
node-ajv Ubuntu:18.04:LTS
- Softwareversionen
- 5.0.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ajv Ubuntu:20.04:LTS
- Softwareversionen
- 6.10.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ajv Ubuntu:22.04:LTS
- Softwareversionen
- 6.12.6-2
- 6.12.6-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ajv Ubuntu:24.04:LTS
- Softwareversionen
- 6.12.6-3
- 8.12.0~ds+~2.1.1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ajv Ubuntu:26.10
- Softwareversionen
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- 8.20.0~ds+~cs6.1.3-1
- 8.20.0~ds+~cs7.1.2-1
- 8.20.0~ds+~cs7.1.3-1
- 8.20.0~ds+~cs7.1.3-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-ajv Ubuntu:26.04:LTS
- Softwareversionen
- 8.12.0~ds+~2.1.1-5
- 8.17.1~ds+~3.0.1+~3.1.0-2
- 8.17.1~ds+~3.0.1+~3.1.0-4build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht