p PatchFirst

CVE-2026-75975

CVE-2026-75975 · fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.

CVSS 7.5 · Élevée · EPSS 0,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • fast-uri

    Versions du logiciel
    • ≥ 2.3.1, < 2.4.5: Concernée (semver)
    • 2.4.5: Non concernée (semver)
    • ≥ 3.0.0, < 3.1.6: Concernée (semver)
    • 3.1.6: Non concernée (semver)
    • ≥ 4.0.0, < 4.1.3: Concernée (semver)
    • 4.1.3: Non concernée (semver)

    Mettez à jour vers 2.4.5; Mettez à jour vers 3.1.6; Mettez à jour vers 4.1.3

  • node-ajv Debian:13

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Debian:14

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    Plages de versions concernées
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1

    Mettez à jour vers 8.20.0~ds+~cs7.1.4-1

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 2.3.1, < 2.4.5

    Mettez à jour vers 2.4.5

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 3.0.0, < 3.1.6

    Mettez à jour vers 3.1.6

  • fast-uri npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.1.3

    Mettez à jour vers 4.1.3

  • node-ajv Ubuntu:18.04:LTS

    Versions du logiciel
    • 5.0.0-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:20.04:LTS

    Versions du logiciel
    • 6.10.2-1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:22.04:LTS

    Versions du logiciel
    • 6.12.6-2
    • 6.12.6-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:24.04:LTS

    Versions du logiciel
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:26.10

    Versions du logiciel
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • node-ajv Ubuntu:26.04:LTS

    Versions du logiciel
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →