p PatchFirst

CVE-2026-75975

CVE-2026-75975 · fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.

CVSS 7.5 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • fast-uri

    Softwareversionen
    • ≥ 2.3.1, < 2.4.5: Betroffen (semver)
    • 2.4.5: Nicht betroffen (semver)
    • ≥ 3.0.0, < 3.1.6: Betroffen (semver)
    • 3.1.6: Nicht betroffen (semver)
    • ≥ 4.0.0, < 4.1.3: Betroffen (semver)
    • 4.1.3: Nicht betroffen (semver)

    Auf 2.4.5 aktualisieren; Auf 3.1.6 aktualisieren; Auf 4.1.3 aktualisieren

  • node-ajv Debian:13

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    • 8.20.0~ds+~cs7.1.6-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Debian:14

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.4-1

    Auf 8.20.0~ds+~cs7.1.4-1 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.3.1, < 2.4.5

    Auf 2.4.5 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.1.6

    Auf 3.1.6 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.1.3

    Auf 4.1.3 aktualisieren

  • node-ajv Ubuntu:18.04:LTS

    Softwareversionen
    • 5.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:20.04:LTS

    Softwareversionen
    • 6.10.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:22.04:LTS

    Softwareversionen
    • 6.12.6-2
    • 6.12.6-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:24.04:LTS

    Softwareversionen
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.10

    Softwareversionen
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.04:LTS

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →