p PatchFirst

CVE-2026-85522

CVE-2026-85522 · valkey-io valkey Slot Migration cluster_migrateslots.c createSlotImportJob out-of-bounds

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

A vulnerability was detected in valkey-io valkey up to 9.5.4/9.1.0. Affected by this vulnerability is the function createSlotImportJob of the file src/cluster_migrateslots.c of the component Slot Migration. The manipulation of the argument job_name results in out-of-bounds read. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 9.0.5 and 9.1.1 addresses this issue. The patch is identified as f4dc3ca09eb650c2fe14060090a41c524eca803f. Upgrading the affected component is advised.

CVSS 6.9 · Moyenne · EPSS 0,9% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · database

Produits et versions concernés

  • valkey

    Versions du logiciel
    • 9.0: Concernée
    • 9.1.0: Concernée
    • 9.5.0: Concernée
    • 9.5.1: Concernée
    • 9.5.2: Concernée
    • 9.5.3: Concernée
    • 9.5.4: Concernée
    • 9.0.5: Non concernée
    • 9.1.1: Non concernée

    Mettez à jour vers 9.0.5; Mettez à jour vers 9.1.1

  • valkey Debian:14

    Versions du logiciel
    • 8.1.1+dfsg1-3
    • 8.1.4+dfsg1-1
    • 8.1.4+dfsg1-2
    • 9.1.1-1
    Plages de versions concernées
    • ECOSYSTEM: < 9.1.2-1

    Mettez à jour vers 9.1.2-1

  • valkey Ubuntu:Pro:24.04:LTS

    Versions du logiciel
    • 7.2.5+dfsg1-2ubuntu4~24.04.1
    • 7.2.7+dfsg1-0ubuntu0.24.04.1
    • 7.2.8+dfsg1-0ubuntu0.24.04.1
    • 7.2.8+dfsg1-0ubuntu0.24.04.2
    • 7.2.8+dfsg1-0ubuntu0.24.04.3
    • 7.2.10+dfsg1-0ubuntu0.1
    • 7.2.11+dfsg1-0ubuntu0.1
    • 7.2.11+dfsg1-0ubuntu0.2
    • 7.2.12+dfsg1-0ubuntu0.1
    • 7.2.13+dfsg1-0ubuntu0.1
    • 7.2.13+dfsg1-0ubuntu0.1+esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • valkey Ubuntu:26.04:LTS

    Versions du logiciel
    • 8.1.3+dfsg1-0ubuntu2
    • 8.1.4+dfsg1-0ubuntu1
    • 9.0.2-0ubuntu1
    • 9.0.3-0ubuntu1
    • 9.0.3-0ubuntu2
    • 9.0.4-0ubuntu0.1
    Plages de versions concernées
    • ECOSYSTEM: < 9.0.4-0ubuntu0.2

    Mettez à jour vers 9.0.4-0ubuntu0.2

Sources originales

Vérifiez votre serveur →