p PatchFirst

CVE-2026-85522

CVE-2026-85522 · valkey-io valkey Slot Migration cluster_migrateslots.c createSlotImportJob out-of-bounds

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was detected in valkey-io valkey up to 9.5.4/9.1.0. Affected by this vulnerability is the function createSlotImportJob of the file src/cluster_migrateslots.c of the component Slot Migration. The manipulation of the argument job_name results in out-of-bounds read. The attack can be executed remotely. The exploit is now public and may be used. Upgrading to version 9.0.5 and 9.1.1 addresses this issue. The patch is identified as f4dc3ca09eb650c2fe14060090a41c524eca803f. Upgrading the affected component is advised.

CVSS 6.9 · Mittel · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · database

Betroffene Produkte und Versionen

  • valkey

    Softwareversionen
    • 9.0: Betroffen
    • 9.1.0: Betroffen
    • 9.5.0: Betroffen
    • 9.5.1: Betroffen
    • 9.5.2: Betroffen
    • 9.5.3: Betroffen
    • 9.5.4: Betroffen
    • 9.0.5: Nicht betroffen
    • 9.1.1: Nicht betroffen

    Auf 9.0.5 aktualisieren; Auf 9.1.1 aktualisieren

  • valkey Debian:14

    Softwareversionen
    • 8.1.1+dfsg1-3
    • 8.1.4+dfsg1-1
    • 8.1.4+dfsg1-2
    • 9.1.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.1.2-1

    Auf 9.1.2-1 aktualisieren

  • valkey Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 7.2.5+dfsg1-2ubuntu4~24.04.1
    • 7.2.7+dfsg1-0ubuntu0.24.04.1
    • 7.2.8+dfsg1-0ubuntu0.24.04.1
    • 7.2.8+dfsg1-0ubuntu0.24.04.2
    • 7.2.8+dfsg1-0ubuntu0.24.04.3
    • 7.2.10+dfsg1-0ubuntu0.1
    • 7.2.11+dfsg1-0ubuntu0.1
    • 7.2.11+dfsg1-0ubuntu0.2
    • 7.2.12+dfsg1-0ubuntu0.1
    • 7.2.13+dfsg1-0ubuntu0.1
    • 7.2.13+dfsg1-0ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • valkey Ubuntu:26.04:LTS

    Softwareversionen
    • 8.1.3+dfsg1-0ubuntu2
    • 8.1.4+dfsg1-0ubuntu1
    • 9.0.2-0ubuntu1
    • 9.0.3-0ubuntu1
    • 9.0.3-0ubuntu2
    • 9.0.4-0ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.0.4-0ubuntu0.2

    Auf 9.0.4-0ubuntu0.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →