p PatchFirst

CVE-2026-92935

CVE-2026-92935 · vm2 NodeVM Remote Code Execution via Array-Shaped Require

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

vm2 is a sandbox for running untrusted Node.js code. In versions >= 3.11.4 and <= 3.11.6, the NodeVM constructor computes `hasRealRequireConfig` with `typeof requireOpts === 'object' && requireOpts !== null`, so an array-shaped `require` value (for example `require: []`) satisfies the guard that is meant to reject nesting without an explicit require configuration. `makeResolverFromLegacyOptions()` then destructures the array into undefined option fields and returns a resolver containing only `NESTING_OVERRIDE.vm2`. As a result, an attacker who can supply JavaScript executed by a NodeVM configured with truthy `nesting` and an array-shaped `require` (e.g. `new NodeVM({nesting: true, require: []})`) can require the host `vm2` module, create an inner NodeVM with an attacker-chosen builtin allowlist (such as `child_process`), and execute arbitrary commands with the privileges of the host Node.js process, escaping the sandbox. Outer builtin restrictions do not constrain the attacker-created inner NodeVM. This issue is fixed in vm2 3.11.7.

CVSS 9.5 · Critique · EPSS 0,7% · Code d’exploitation public · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • vm2

    Versions du logiciel
    • ≥ 3.11.4, < 3.11.7: Concernée (semver)
    • 3.11.7: Non concernée (semver)

    Mettez à jour vers 3.11.7

  • vm2 npm

    Plages de versions concernées
    • SEMVER: ≥ 3.11.4, < 3.11.7

    Mettez à jour vers 3.11.7

Sources originales

Vérifiez votre serveur →