p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de knot-resolver

Vulnérabilités publiées pour knot-resolver au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

RSS ↗
Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 14

  1. CVE-2023-50868

    Élevée · CVSS 7.5EPSS 74,3%Correctif disponible

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Mettez à jour vers 5.7.1-1
    Publication Mise à jour
  2. CVE-2023-50387

    Élevée · CVSS 7.5EPSS 99,99%Correctif disponible

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Mettez à jour vers 5.7.1-1
    Publication Mise à jour
  3. CVE-2023-26249

    Élevée · CVSS 7.5EPSS 0,71%Correctif disponible

    CVE-2023-26249

    Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially causing a denial of service. Specifically, a single client query may lead to a hundred TCP connection attempts if a DNS server closes connections without providing a response.

    • Mettez à jour vers 5.6.0-1
    Publication Mise à jour
  4. CVE-2019-19331

    Élevée · CVSS 7.5EPSS 2,11%Correctif disponible

    CVE-2019-19331

    knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with very many resource records might be processed very inefficiently, in extreme cases taking even several CPU seconds for each such uncached message. For example, a few thousand A records can be squashed into one DNS message (limit is 64kB).

    • Mettez à jour vers 5.0.1-1
    Publication Mise à jour
  5. CVE-2019-10191

    Moyenne · CVSS 6.3EPSS 1,93%Correctif disponible

    CVE-2019-10191

    A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of domain hijack using attacks against insecure DNS protocol.

    • Mettez à jour vers 5.0.1-1
    Publication Mise à jour
  6. CVE-2019-10190

    Moyenne · CVSS 5.4EPSS 1,99%Correctif disponible

    CVE-2019-10190

    A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 which allows remote attackers to bypass DNSSEC validation for non-existence answer. NXDOMAIN answer would get passed through to the client even if its DNSSEC validation failed, instead of sending a SERVFAIL packet. Caching is not affected by this particular bug but see CVE-2019-10191.

    • Mettez à jour vers 5.0.1-1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →