p PatchFirst

PatchFirst · Latest vulnerabilities

knot-resolver vulnerabilities

Vulnerabilities published for knot-resolver in the last 30 days: 0. Listed in the KEV catalogue: 0.

RSS ↗
Filter vulnerabilities
Clear filters

Vulnerabilities: 14

  1. CVE-2023-50868

    High · CVSS 7.5EPSS 74.3%Fix available

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Update to 5.7.1-1
    Published Updated
  2. CVE-2023-50387

    High · CVSS 7.5EPSS 99.99%Fix available

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Update to 5.7.1-1
    Published Updated
  3. CVE-2023-26249

    High · CVSS 7.5EPSS 0.71%Fix available

    CVE-2023-26249

    Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially causing a denial of service. Specifically, a single client query may lead to a hundred TCP connection attempts if a DNS server closes connections without providing a response.

    • Update to 5.6.0-1
    Published Updated
  4. CVE-2019-19331

    High · CVSS 7.5EPSS 2.11%Fix available

    CVE-2019-19331

    knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with very many resource records might be processed very inefficiently, in extreme cases taking even several CPU seconds for each such uncached message. For example, a few thousand A records can be squashed into one DNS message (limit is 64kB).

    • Update to 5.0.1-1
    Published Updated
  5. CVE-2019-10190

    Medium · CVSS 5.4EPSS 1.99%Fix available

    CVE-2019-10190

    A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 which allows remote attackers to bypass DNSSEC validation for non-existence answer. NXDOMAIN answer would get passed through to the client even if its DNSSEC validation failed, instead of sending a SERVFAIL packet. Caching is not affected by this particular bug but see CVE-2019-10191.

    • Update to 5.0.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →