p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in knot-resolver

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für knot-resolver: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 14

  1. CVE-2023-50868

    Hoch · CVSS 7.5EPSS 74,3%Korrektur verfügbar

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Auf 5.7.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2023-50387

    Hoch · CVSS 7.5EPSS 99,99%Korrektur verfügbar

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Auf 5.7.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2023-26249

    Hoch · CVSS 7.5EPSS 0,71%Korrektur verfügbar

    CVE-2023-26249

    Knot Resolver before 5.6.0 enables attackers to consume its resources, launching amplification attacks and potentially causing a denial of service. Specifically, a single client query may lead to a hundred TCP connection attempts if a DNS server closes connections without providing a response.

    • Auf 5.6.0-1 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2019-19331

    Hoch · CVSS 7.5EPSS 2,11%Korrektur verfügbar

    CVE-2019-19331

    knot-resolver before version 4.3.0 is vulnerable to denial of service through high CPU utilization. DNS replies with very many resource records might be processed very inefficiently, in extreme cases taking even several CPU seconds for each such uncached message. For example, a few thousand A records can be squashed into one DNS message (limit is 64kB).

    • Auf 5.0.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2019-10191

    Mittel · CVSS 6.3EPSS 1,93%Korrektur verfügbar

    CVE-2019-10191

    A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of domain hijack using attacks against insecure DNS protocol.

    • Auf 5.0.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2019-10190

    Mittel · CVSS 5.4EPSS 1,99%Korrektur verfügbar

    CVE-2019-10190

    A vulnerability was discovered in DNS resolver component of knot resolver through version 3.2.0 before 4.1.0 which allows remote attackers to bypass DNSSEC validation for non-existence answer. NXDOMAIN answer would get passed through to the client even if its DNSSEC validation failed, instead of sending a SERVFAIL packet. Caching is not affected by this particular bug but see CVE-2019-10191.

    • Auf 5.0.1-1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2018-1000002

    Niedrig · CVSS 3.7EPSS 1,08%Korrektur verfügbar

    CVE-2018-1000002

    Improper input validation bugs in DNSSEC validators components in Knot Resolver (prior version 1.5.2) allow attacker in man-in-the-middle position to deny existence of some data in DNS via packet replay.

    • Auf 1.5.2-1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →