p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de rustc · Page n° 2

Vulnérabilités publiées pour rustc au cours des 30 derniers jours : 0. Présentes dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 23

  1. CVE-2018-1000810

    Critique · CVSS 9.8EPSS 2,99%Correctif disponible

    CVE-2018-1000810

    The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

    • Mettez à jour vers 1.30.0+dfsg1-1
    Publication Mise à jour
  2. CVE-2018-1000657

    Élevée · CVSS 7.8EPSS 0,54%Correctif disponible

    CVE-2018-1000657

    Rust Programming Language Rust standard library version Commit bfa0e1f58acf1c28d500c34ed258f09ae021893e and later; stable release 1.3.0 and later contains a Buffer Overflow vulnerability in std::collections::vec_deque::VecDeque::reserve() function that can result in Arbitrary code execution, but no proof-of-concept exploit is currently published.. This vulnerability appears to have been fixed in after commit fdfafb510b1a38f727e920dccbeeb638d39a8e60; stable release 1.22.0 and later.

    • Mettez à jour vers 1.22.1+dfsg1-1
    Publication Mise à jour
  3. CVE-2018-1000622

    Élevée · CVSS 7.8EPSS 1,82%Correctif disponible

    CVE-2018-1000622

    The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

    • Mettez à jour vers 1.27.1+dfsg1-1~exp1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →