p PatchFirst

CVE-2018-1000622

CVE-2018-1000622

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

The Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.

CVSS 7.8 · Élevée · EPSS 1,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • rustc Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.27.1+dfsg1-1~exp1

    Mettez à jour vers 1.27.1+dfsg1-1~exp1

  • rustc Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.27.1+dfsg1-1~exp1

    Mettez à jour vers 1.27.1+dfsg1-1~exp1

  • rustc Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.27.1+dfsg1-1~exp1

    Mettez à jour vers 1.27.1+dfsg1-1~exp1

Sources originales

Vérifiez votre serveur →