p PatchFirst

CVE-2018-1000810

CVE-2018-1000810

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.

CVSS 9.8 · Critique · EPSS 3,0% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • n/a

    Versions du logiciel
    • n/a: Concernée

    Aucun correctif publié

  • rustc Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Mettez à jour vers 1.30.0+dfsg1-1

  • rustc Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Mettez à jour vers 1.30.0+dfsg1-1

  • rustc Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.30.0+dfsg1-1

    Mettez à jour vers 1.30.0+dfsg1-1

Sources originales

Vérifiez votre serveur →