p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de pygments

Vulnérabilité publiée pour pygments au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2026-4539

    Moyenne · CVSS 4.8EPSS 0,16%Correctif disponible

    pygments archetype.py AdlLexer redos

    A security flaw has been discovered in pygments up to 2.19.2. The impacted element is the function AdlLexer of the file pygments/lexers/archetype.py. The manipulation results in inefficient regular expression complexity. The attack is only possible with local access. The exploit has been released to the public and may be used for attacks. The project was informed of the problem early through an issue report but has not responded yet.

    • Mettez à jour vers 2.20.0+dfsg-1
    Publication Mise à jour
  2. CVE-2021-27291

    Élevée · CVSS 8.7EPSS 3,91%Correctif disponible

    CVE-2021-27291

    In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.

    • Mettez à jour vers 2.7.1+dfsg-2.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →