CVE-2021-27291
CVE-2021-27291
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
CVSS 8.7 · Élevée · EPSS 3,9% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
n/a
- Versions du logiciel
- n/a: Concernée
Aucun correctif publié
mediawiki Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1:1.35.2-1
Mettez à jour vers 1:1.35.2-1
mediawiki Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1:1.35.2-1
Mettez à jour vers 1:1.35.2-1
mediawiki Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1:1.35.2-1
Mettez à jour vers 1:1.35.2-1
pygments Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 2.7.1+dfsg-2.1
Mettez à jour vers 2.7.1+dfsg-2.1
pygments Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 2.7.1+dfsg-2.1
Mettez à jour vers 2.7.1+dfsg-2.1
pygments Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 2.7.1+dfsg-2.1
Mettez à jour vers 2.7.1+dfsg-2.1
pygments PyPI
- Versions du logiciel
- 1.1
- 1.1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.3
- 1.3.1
- 1.4
- 1.5
- 1.6
- 1.6rc1
- 2.0
- 2.0.1
- 2.0.2
- 2.0rc1
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.1, < 2.7.4
Mettez à jour vers 2.7.4
pygments PyPI
- Versions du logiciel
- 1.1
- 1.1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.3
- 1.3.1
- 1.4
- 1.5
- 1.6
- 1.6rc1
- 2.0
- 2.0.1
- 2.0.2
- 2.0rc1
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.2.0
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.4.2
- 2.5.1
- 2.5.2
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.7.2
- 2.7.3
- Plages de versions concernées
- GIT: < 2e7e8c4a7b318f4032493773732754e418279a14
- ECOSYSTEM: ≥ 1.1, < 2.7.4
Mettez à jour vers 2.7.4
pygments Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.6+dfsg-1
- 1.6+dfsg-1build1
- 1.6+dfsg-1ubuntu1
- 1.6+dfsg-1ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6+dfsg-1ubuntu1.1+esm1
Mettez à jour vers 1.6+dfsg-1ubuntu1.1+esm1
pygments Ubuntu:16.04:LTS
- Versions du logiciel
- 2.0.1+dfsg-1.1svn1
- 2.0.1+dfsg-1.1ubuntu1
- 2.1+dfsg-1
- 2.1+dfsg-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 2.1+dfsg-1ubuntu0.2
Mettez à jour vers 2.1+dfsg-1ubuntu0.2
eric Ubuntu:16.04:LTS
- Versions du logiciel
- 6.0.8-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pygments Ubuntu:18.04:LTS
- Versions du logiciel
- 2.2.0+dfsg-1
- 2.2.0+dfsg-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 2.2.0+dfsg-1ubuntu0.2
Mettez à jour vers 2.2.0+dfsg-1ubuntu0.2
eric Ubuntu:18.04:LTS
- Versions du logiciel
- 17.08-1
- 17.11.1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
pygments Ubuntu:20.04:LTS
- Versions du logiciel
- 2.3.1+dfsg-1ubuntu1
- 2.3.1+dfsg-1ubuntu2
- 2.3.1+dfsg-1ubuntu2.1
- Plages de versions concernées
- ECOSYSTEM: < 2.3.1+dfsg-1ubuntu2.2
Mettez à jour vers 2.3.1+dfsg-1ubuntu2.2
eric Ubuntu:20.04:LTS
- Versions du logiciel
- 19.02.1+ds1-1
- 19.8+ds1-1
- 19.12+ds1-1
- 20.1+ds1-1
- 20.2+ds1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
eric Ubuntu:22.04:LTS
- Versions du logiciel
- 21.1+ds1-1
- 21.1+ds1-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
eric Ubuntu:24.04:LTS
- Versions du logiciel
- 23.2+ds1-1
- 23.2+ds1-2
- 23.2+ds1-2ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
eric Ubuntu:25.10
- Versions du logiciel
- 24.3+ds1-1
- 24.8+ds1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
eric Ubuntu:26.10
- Versions du logiciel
- 24.8+ds1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
eric Ubuntu:26.04:LTS
- Versions du logiciel
- 24.8+ds1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://gist.github.com/b-c-ds/b1a2cc0c68a35c57188575eb496de5ce
- https://github.com/pygments/pygments/commit/2e7e8c4a7b318f4032493773732754e418279a14
- https://lists.debian.org/debian-lts-announce/2021/03/msg00024.html
- https://www.debian.org/security/2021/dsa-4878
- https://www.debian.org/security/2021/dsa-4889
- https://lists.debian.org/debian-lts-announce/2021/05/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GSJRFHALQ7E3UV4FFMFU2YQ6LUDHAI55/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WSLD67LFGXOX2K5YNESSWAS4AGZIJTUQ/
- https://lists.debian.org/debian-lts-announce/2021/05/msg00006.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-27291