p PatchFirst

GHSA-g9jg-w8vm-g96v

GHSA-g9jg-w8vm-g96v · Trix has a stored XSS vulnerability through its attachment attribute

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

### Impact The Trix editor, in versions prior to 2.1.16, is vulnerable to XSS attacks through attachment payloads. An attacker could inject malicious code into a data-trix-attachment attribute that, when rendered as HTML and clicked on, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. ### Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.16 or later. ### Resources The XSS vulnerability was reported by HackerOne researcher [michaelcheers](https://hackerone.com/michaelcheers?type=user).

CVSS 4.6 · Moyenne · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • trix npm

    Plages de versions concernées
    • SEMVER: < 2.1.16

    Mettez à jour vers 2.1.16

  • action_text-trix RubyGems

    Versions du logiciel
    • 0.0.1
    • 2.1.15
    Plages de versions concernées
    • ECOSYSTEM: < 2.1.16

    Mettez à jour vers 2.1.16

Sources originales

Vérifiez votre serveur →