p PatchFirst

GHSA-g9jg-w8vm-g96v

GHSA-g9jg-w8vm-g96v · Trix has a stored XSS vulnerability through its attachment attribute

This page contains facts from public vulnerability sources. Check the original advisory before updating.

### Impact The Trix editor, in versions prior to 2.1.16, is vulnerable to XSS attacks through attachment payloads. An attacker could inject malicious code into a data-trix-attachment attribute that, when rendered as HTML and clicked on, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. ### Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.16 or later. ### Resources The XSS vulnerability was reported by HackerOne researcher [michaelcheers](https://hackerone.com/michaelcheers?type=user).

CVSS 4.6 · Medium · Fix available

Published
Updated

Stack: node

Affected products and versions

  • trix npm

    Affected ranges
    • SEMVER: < 2.1.16

    Update to 2.1.16

  • action_text-trix RubyGems

    Versions
    • 0.0.1
    • 2.1.15
    Affected ranges
    • ECOSYSTEM: < 2.1.16

    Update to 2.1.16

Original sources

Check your server →