p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de @account-kit/smart-contracts

Vulnérabilité publiée pour @account-kit/smart-contracts au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 2

  1. GHSA-56r6-ccm5-8hg3

    Critique · CVSS 9.3Correctif disponible

    Alchemy Non-SMA and Webauthn Account Security Advisory

    ### Impact A potential security issue has been mitigated on old account deployment functions from the factory. Smart wallets in use on all existing supported networks are not impacted. ### Patches Please direct creation of new wallets to either `createSemiModularAccount` on `AccountFactory.sol` or `createWebAuthnAccount` on `WebAuthnFactory.sol`.

    • Mettez à jour vers 4.52.0
    Publication Mise à jour
  2. GHSA-wfm2-rq5g-f8v5

    Élevée · CVSS 8.7Correctif disponible

    @account-kit/smart-contracts Allowlist Module Bypass Vulnerability

    ### Summary Allowlist module contains a bypass vulnerability ### Details The logic for using an allowlist on a Modular Account V2 contained a bug that allowed session keys to bypass any allowlist configuration ### Action If you are using @aa-sdk and/or @account-kit/smart-contracts between the versions of >=4.8.0 and <4.28.1, please upgrade to 4.28.2

    • Mettez à jour vers 4.28.2
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →