p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de auth0-js

Vulnérabilité publiée pour auth0-js au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2026-42280

    Élevée · CVSS 7.1EPSS 0,21%Correctif disponible

    Improper Permission Checking in Auth.js SDK

    Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.

    • Mettez à jour vers 10.0.0
    Publication Mise à jour
  2. CVE-2020-5263

    Moyenne · CVSS 5.5EPSS 0,87%Correctif disponible

    Information disclosure through error object

    auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

    • Mettez à jour vers 9.13.2
    Publication Mise à jour
  3. CVE-2018-7307

    Élevée · CVSS 8.8EPSS 0,51%Correctif disponible

    CVE-2018-7307

    The Auth0 Auth0.js library before 9.3 has CSRF because it mishandles the case where the authorization response lacks the state parameter.

    • Mettez à jour vers 9.3.0
    Publication Mise à jour
  4. CVE-2017-17068

    Élevée · CVSS 7.5EPSS 1,42%Correctif disponible

    CVE-2017-17068

    A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().

    • Mettez à jour vers 8.12.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →