p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de debug

Vulnérabilité publiée pour debug au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 3

  1. CVE-2025-59144

    Élevée · CVSS 8.8EPSS 0,48%Correctif disponible

    [email protected] contains malware after npm account takeover

    debug is a JavaScript debugging utility. On 8 September 2025, the npm publishing account for debug was taken over after a phishing attack. Version 4.4.2 was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments. Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct <script> inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there is a chance the malware still exis

    • Mettez à jour vers 4.4.3
    Publication Mise à jour
  2. CVE-2017-20165

    Faible · CVSS 3.5EPSS 2,1%Correctif disponible

    debug-js debug node.js useColors redos

    A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.

    • Mettez à jour vers 2.6.9
    • Mettez à jour vers 3.1.0
    Publication Mise à jour
  3. CVE-2017-16137

    Moyenne · CVSS 5.3EPSS 2,83%Correctif disponible

    CVE-2017-16137

    The debug module is vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter. It takes around 50k characters to block for 2 seconds making this a low severity issue.

    • Mettez à jour vers 2.6.9
    • Mettez à jour vers 3.1.0
    • Mettez à jour vers 3.2.7
    • Mettez à jour vers 4.3.1
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →