p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in debug

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für debug: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 3

  1. CVE-2025-59144

    Hoch · CVSS 8.8EPSS 0,48%Korrektur verfügbar

    [email protected] contains malware after npm account takeover

    debug is a JavaScript debugging utility. On 8 September 2025, the npm publishing account for debug was taken over after a phishing attack. Version 4.4.2 was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments. Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct <script> inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there is a chance the malware still exis

    • Auf 4.4.3 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2017-20165

    Niedrig · CVSS 3.5EPSS 2,1%Korrektur verfügbar

    debug-js debug node.js useColors redos

    A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.

    • Auf 2.6.9 aktualisieren
    • Auf 3.1.0 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2017-16137

    Mittel · CVSS 5.3EPSS 2,83%Korrektur verfügbar

    CVE-2017-16137

    The debug module is vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter. It takes around 50k characters to block for 2 seconds making this a low severity issue.

    • Auf 2.6.9 aktualisieren
    • Auf 3.1.0 aktualisieren
    • Auf 3.2.7 aktualisieren
    • Auf 4.3.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →