p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de mongoose

Vulnérabilité publiée pour mongoose au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 9

  1. CVE-2026-73562

    Moyenne · CVSS 6.5EPSS 0,5%Correctif disponible

    Mongoose: Prototype pollution in the update casting via __proto__-prefixed dotted path (Schema._getSchema/path getter)

    Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.10, 7.8.10, 8.24.1, and 9.7.2, passing a user-controlled update such as MyModel.updateOne(filter, req.body) can exploit Mongoose update casting with a __proto__.x dotted path under $set. Schema.prototype.path and Schema.prototype._getPathType can treat inherited properties of schema.paths and schema.nested as schema types, allowing the casting process to set $fullPath and $parentSchemaDocArray on Object.prototype before throwing. This prototype pollution makes those properties visible on newly created objects and can cause application int

    • Mettez à jour vers 6.13.10
    • Mettez à jour vers 7.8.10
    • Mettez à jour vers 8.24.1
    • Mettez à jour vers 9.7.2
    Publication Mise à jour
  2. CVE-2026-42334

    Élevée · CVSS 7.5EPSS 0,27%Correctif disponible

    Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection

    Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being saniti

    • Mettez à jour vers 6.13.9
    • Mettez à jour vers 7.8.9
    • Mettez à jour vers 8.22.1
    • Mettez à jour vers 9.1.6
    Publication Mise à jour
  3. CVE-2025-23061

    Critique · CVSS 9EPSS 7,24%Code d’exploitation publicCorrectif disponible

    CVE-2025-23061

    Mongoose before 8.9.5 can improperly use a nested $where filter with a populate() match, leading to search injection. NOTE: this issue exists because of an incomplete fix for CVE-2024-53900.

    • Mettez à jour vers 6.13.6
    • Mettez à jour vers 7.8.4
    • Mettez à jour vers 8.9.5
    Publication Mise à jour
  4. CVE-2022-24304

    Critique · CVSS 9.8Correctif disponible

    Mongoose Vulnerable to Prototype Pollution in Schema Object

    ### Description Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Affected versions of this package are vulnerable to Prototype Pollution. The `Schema.path()` function is vulnerable to prototype pollution when setting the `schema` object. This vulnerability allows modification of the Object prototype and could be manipulated into a Denial of Service (DoS) attack. ### Proof of Concept ```js // poc.js const mongoose = require('mongoose'); const schema = new mongoose.Schema(); malicious_payload = '__proto__.toString' schema.path(malicious_payload, [String]) x = {} console.log(x.toString()) // crashe

    • Mettez à jour vers 5.13.15
    • Mettez à jour vers 6.4.6
    Publication Mise à jour
  5. GHSA-r5xw-q988-826m

    Moyenne · CVSS 5.1Correctif disponible

    Remote Memory Exposure in mongoose

    Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.

    • Mettez à jour vers 3.8.39
    • Mettez à jour vers 4.3.6
    Publication Mise à jour
  6. CVE-2019-17426

    Critique · CVSS 9.1EPSS 1,5%Correctif disponible

    CVE-2019-17426

    Automattic Mongoose through 5.7.4 allows attackers to bypass access control (in some applications) because any query object with a _bsontype attribute is ignored. For example, adding "_bsontype":"a" can sometimes interfere with a query filter. NOTE: this CVE is about Mongoose's failure to work around this _bsontype special case that exists in older versions of the bson parser (aka the mongodb/js-bson project).

    • Mettez à jour vers 4.13.21
    • Mettez à jour vers 5.7.5
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →