p PatchFirst

GHSA-r5xw-q988-826m

GHSA-r5xw-q988-826m · Remote Memory Exposure in mongoose

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Versions of `mongoose` before 4.3.6, 3.8.39 are vulnerable to remote memory exposure. Trying to save a number to a field of type Buffer on the affected mongoose versions allocates a chunk of uninitialized memory and stores it in the database. ## Recommendation Update to version 4.3.6, 3.8.39 or later.

CVSS 5.1 · Moyenne · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • mongoose npm

    Plages de versions concernées
    • SEMVER: ≥ 3.5.5, < 3.8.39

    Mettez à jour vers 3.8.39

  • mongoose npm

    Plages de versions concernées
    • SEMVER: ≥ 4.0.0, < 4.3.6

    Mettez à jour vers 4.3.6

Sources originales

Vérifiez votre serveur →