p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de ua-parser-js

Vulnérabilité publiée pour ua-parser-js au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 6

  1. CVE-2026-48125

    Moyenne · CVSS 5.3EPSS 0,52%Correctif disponible

    UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()`

    UAParser.js is a JavaScript library to detect browsers, operating systems, CPUs, and devices from user-agent data. From 2.0.1 until 2.0.10, a regular expression denial-of-service vulnerability exists when using the Client Hints API. By sending a crafted Sec-CH-UA-Model header to an application that calls UAParser(headers).withClientHints(), an attacker can cause excessive CPU time due to catastrophic backtracking in the device regex because Client Hints values are copied without the UA_MAX_LENGTH limit used for User-Agent values. This issue is fixed in version 2.0.10.

    • Mettez à jour vers 2.0.10
    Publication Mise à jour
  2. CVE-2021-4229

    Moyenne · CVSS 5EPSS 1,52%Correctif disponible

    ua-parser-js Crypto Mining backdoor

    A vulnerability was found in ua-parser-js 0.7.29/0.8.0/1.0.0. It has been rated as critical. This issue affects the crypto mining component which introduces a backdoor. Upgrading to version 0.7.30, 0.8.1 and 1.0.1 is able to address this issue. It is recommended to upgrade the affected component.

    • Mettez à jour vers 0.7.30
    • Mettez à jour vers 0.8.1
    • Mettez à jour vers 1.0.1
    Publication Mise à jour
  3. CVE-2021-27292

    Élevée · CVSS 7.5EPSS 3,37%Correctif disponible

    CVE-2021-27292

    ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

    • Mettez à jour vers 0.7.24
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →