p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ua-parser-js

Vulnerabilidades publicadas para ua-parser-js en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 6

  1. CVE-2026-48125

    Media · CVSS 5.3EPSS 0,52%Corrección disponible

    UAParser.js: Unbounded `Sec-CH-UA-Model` parsing can trigger ReDoS in `withClientHints()`

    UAParser.js is a JavaScript library to detect browsers, operating systems, CPUs, and devices from user-agent data. From 2.0.1 until 2.0.10, a regular expression denial-of-service vulnerability exists when using the Client Hints API. By sending a crafted Sec-CH-UA-Model header to an application that calls UAParser(headers).withClientHints(), an attacker can cause excessive CPU time due to catastrophic backtracking in the device regex because Client Hints values are copied without the UA_MAX_LENGTH limit used for User-Agent values. This issue is fixed in version 2.0.10.

    • Actualiza a 2.0.10
    Publicación Actualización
  2. CVE-2021-4229

    Media · CVSS 5EPSS 1,52%Corrección disponible

    ua-parser-js Crypto Mining backdoor

    A vulnerability was found in ua-parser-js 0.7.29/0.8.0/1.0.0. It has been rated as critical. This issue affects the crypto mining component which introduces a backdoor. Upgrading to version 0.7.30, 0.8.1 and 1.0.1 is able to address this issue. It is recommended to upgrade the affected component.

    • Actualiza a 0.7.30
    • Actualiza a 0.8.1
    • Actualiza a 1.0.1
    Publicación Actualización
  3. CVE-2021-27292

    Alta · CVSS 7.5EPSS 3,37%Corrección disponible

    CVE-2021-27292

    ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

    • Actualiza a 0.7.24
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →