p PatchFirst

PatchFirst · Vulnérabilités récentes

Vulnérabilités de automad/automad

Vulnérabilité publiée pour automad/automad au cours des 30 derniers jours : 0. Dans le catalogue KEV : 0.

Filtrer les vulnérabilités
Effacer les filtres

Vulnérabilités : 5

  1. CVE-2026-45332

    Élevée · CVSS 7.5EPSS 1,42%Code d’exploitation publicCorrectif disponible

    Automad Broken Access Control: unauthenticated exposure of administrator bcrypt password hashes and TOTP secrets via public API endpoint

    Automad is a flat-file content management system and template engine. From 2.0.0-alpha.1 to 2.0.0-beta.27, a Broken Access Control vulnerability allows an unauthenticated attacker to retrieve the bcrypt password hash of every administrator account with a single POST request. The /_api/user-collection/create-first-user setup endpoint remains publicly accessible once initial configuration is complete and returns full serialized user data in the JSON response body. This vulnerability is fixed in 2.0.0-beta.28.

    • Mettez à jour vers 2.0.0-beta.28
    Publication Mise à jour
  2. CVE-2024-40400

    Élevée · CVSS 8.8EPSS 0,81%Correctif disponible

    CVE-2024-40400

    An arbitrary file upload vulnerability in the image upload function of Automad v2.0.0 allows attackers to execute arbitrary code via a crafted file.

    • Mettez à jour vers 2.0.0-alpha.5
    Publication Mise à jour
  3. CVE-2023-7038

    Moyenne · CVSS 4.3EPSS 0,39%Correctif disponible

    automad User Creation cross-site request forgery

    A vulnerability was found in automad up to 1.10.9. It has been rated as problematic. This issue affects some unknown processing of the file /dashboard?controller=UserCollection::createUser of the component User Creation Handler. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-248687. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

    • Mettez à jour vers 2.0.0-alpha.1
    Publication Mise à jour
  4. CVE-2023-7037

    Moyenne · CVSS 6.3EPSS 0,71%Aucun correctif publié

    automad FileController.php import server-side request forgery

    A vulnerability was found in automad up to 1.10.9. It has been declared as critical. This vulnerability affects the function import of the file FileController.php. The manipulation of the argument importUrl leads to server-side request forgery. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. VDB-248686 is the identifier assigned to this vulnerability. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

    Publication Mise à jour
  5. CVE-2021-37502

    Moyenne · CVSS 5.4EPSS 0,52%Correctif disponible

    CVE-2021-37502

    Cross Site Scripting (XSS) vulnerability in automad 1.7.5 allows remote attackers to run arbitrary code via the user name field when adding a user.

    • Mettez à jour vers 1.8.0
    Publication Mise à jour

Vérifiez votre serveur

Comparez votre pile et les versions installées aux bases de vulnérabilités actuelles.

Vérifiez votre serveur →