p PatchFirst

PatchFirst · Latest vulnerabilities

automad/automad vulnerabilities

Vulnerabilities published for automad/automad in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 5

  1. CVE-2026-45332

    High · CVSS 7.5EPSS 1.42%Public exploitFix available

    Automad Broken Access Control: unauthenticated exposure of administrator bcrypt password hashes and TOTP secrets via public API endpoint

    Automad is a flat-file content management system and template engine. From 2.0.0-alpha.1 to 2.0.0-beta.27, a Broken Access Control vulnerability allows an unauthenticated attacker to retrieve the bcrypt password hash of every administrator account with a single POST request. The /_api/user-collection/create-first-user setup endpoint remains publicly accessible once initial configuration is complete and returns full serialized user data in the JSON response body. This vulnerability is fixed in 2.0.0-beta.28.

    • Update to 2.0.0-beta.28
    Published Updated
  2. CVE-2023-7038

    Medium · CVSS 4.3EPSS 0.39%Fix available

    automad User Creation cross-site request forgery

    A vulnerability was found in automad up to 1.10.9. It has been rated as problematic. This issue affects some unknown processing of the file /dashboard?controller=UserCollection::createUser of the component User Creation Handler. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-248687. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

    • Update to 2.0.0-alpha.1
    Published Updated
  3. CVE-2023-7037

    Medium · CVSS 6.3EPSS 0.71%No fix published

    automad FileController.php import server-side request forgery

    A vulnerability was found in automad up to 1.10.9. It has been declared as critical. This vulnerability affects the function import of the file FileController.php. The manipulation of the argument importUrl leads to server-side request forgery. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. VDB-248686 is the identifier assigned to this vulnerability. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →